|
1.415.462.1982

Maxon Cinema S22 Compatibility – The Definitive List – Updated 26 May 2020

Cinema 4D S22 Compatibility

We’re elated about the release of Maxon Cinema 4D S22, the first subscription-only release. But, as with any major release, the issue of compatibility comes into play.

Developers are working diligently to make sure everything will work smoothly with the new S22 release.

We have put together a list of products and information to keep you informed about plug-in and product compatibility. Please let us know if you have any information that should be included on this list. We will be updating this page as new information is learned. Look for the New badge.


Maxon Cinema 4D S22 What are Cinema 4D S22’s System Requirements?

Minimum System Requirements Cinema 4D

Windows 10 64-bit on Intel or AMD 64-bit CPU with SSE3 support or MacOS 10.12.6+ with 64-bit CPU running on Intel-based Apple Macintosh 4 GB RAM (8 GB or more recommended), OpenGL graphics card supporting OpenGL 4.1 (dedicated GPU recommended)

The GPU renderer requires an NVIDIA or AMD graphics card on Windows or AMD on MacOS that supports OpenCL 1.2 or newer. Metal support requires MacOS 10.14.6 or newer. We recommend at least 4 GB VRAM for GPU rendering.

Full System Requirements


Cinema S22 Compatibility

Cinemaplugins  New

DEM Earth version 4.022 works with S22.

LAZPoint is NOT currently compatible with S22, as OpenGL was removed with no replacement framework available to plugin developers.

Updated on 26 May 2020


greyscalegorilla

Greyscalegorilla

Updated on 28 April 2020

All Greyscalegorilla products have compatibility updates for Cinema 4D S22, including:

If you require updated installers for use with S22, please contact us at sales@toolfarm.com with your original order #.
Updated on 28 April 2020

Heyne Multimedia

Heyne products will work with S22. Specifically, users of R21 should copy both the folder containing the plugin and the license file to the new release.

Updated on 30 April 2020


Jawset

Jawset TurbulenceFD for Cinema 4D has been updated for S22, Windows version. The current Windows build of TurbulenceFD supports all Cinema 4D versions from R15 to S22. The current macOS build supports R15 through R21. An update for S22 on MacOS will become available soon.

Updated on 28 April 2020


Mike Udin

All products are compatible.

Updated 4 May 2020


Pixel Lab

All products are compatible.

Updated 14 May 2020


Redshift

Redshift v2.6.54 added support for S22. In fact, the latest installers are below.

Updated 4 May 2020


Renderking

In summary, all Renderking products are compatible with S22.

Updated on 30 April 2020


Rizom Labs

RizomUV is compatible with S22. Furthermore, there is a bridge which transfers UVs from C4D to RizomUV and back.

Updated 4 May 2020


Rodenberg

Rodenberg products are NOT compatible just yet but there is an update in the works.

Updated on 30 April 2020


U-RENDER

In short, U-RENDER 2020.04.04 adds support for Cinema 4D S22.

[product_demo_link class=”margin-mobile-btn btn btn-primary” product_id=22163 demo_id=22179 label=”Try U-RENDER for free!”]

Updated on 1 May 2020

Posted by Michele Yamazaki